Uh why my render view quality weird like its have opacity


Uploading: Screenshot_32.png…
this is the picture of rendered
i have same problem when i post 3d of zephyrus g14 too i thought its just a bug but this zephyrus duo 16 have same problem

hi there, have you got this published on sketchfab already? is it possible to share a link to it?

i haven’t posted it yet. but i try to post and send the link


here’s the link of 3d

Um, this looks good to me, did you solve the problem in the end?

I noticed the keys on the keyboard appear like its a flat surface (similar to the numerical keys area)
did you try use a little bit of sketchfab AO to help define that the keys are raised? It might not be effective with your dark colors, but it might be worth a try.

another suggestion would be to make each key glow on their edges too (which ive seen some keyboards do)

as a crude example ,… (please ignore the wireframe)

The keys look like that because every vertex normal is facing straight upward. Could be fixed by recalculating the normals with Set to Face in Maya, or Normals > Auto Smooth in Blender. Unless that effect was intended.

As for the weird opacity look, perhaps it’s somehow caused by the Screen Space Reflection, Post Processing Filter, I’m not sure.

Um, could be, it might also be your gpu not rendering properly, i think on some very rare occasions i had some issues that seemed to sort themselves out after i modified some settings or updated my gpu drivers, but im not sure this would relate to the problem you are having.

Are you still seeing the issue?

This is my another 3d like this model

But tthis model doesnt have bug render like this

Hmmm i tried to view with phone and the render still like that

Hmmmm lemme try it


i tried with my another model and still same…

kirigami318 - Sketchfab
this is my another last model i posted and not having problem like my latest model.
btw im using blender v3.1.2.

It looks again as if the models vertex normals are probably strange, like if every cube has all of it’s vertex normals facing in one single direction, giving it a super flat weird shading, and some become pale when they reflect highlight in that weird super flat way, I am guessing.

If you check Model Inspector > Vertex Normals in the Editor you should see if that may be the case.