Unable to authorize 3ds Max exporter

exporter
3dsmax

(Philip3d) #1

I can't seem to authorize the exporter for 3ds max. I just get a blank window when I click authorize. Above the 'authorize' button in the Sketchfab exporter menu says "unauthorized, HTTP Status Code: 401". Can anyone help?


Blank Sketchfab Authentication Box - 3ds Max
(Klaasnienhuis) #2

Hi @philip3d,
Have you restarted 3dsMax after you've installed the exporter? You only need to do this once.


(Philip3d) #3

Thanks for responding. I still get the same error after restarting.


(Klaasnienhuis) #4

@philip3d,
Bummer!
What 3dsMax version are you on? It looks like you're using windows 8, is that correct? I'm developing on a win7 machine and can't test if win8 performs differently. And could you try to log into Sketchfab with Internet Explorer (that's what the popup is supposed to be) and tell me what happens?

Finally, if you're brave, you can check your registry. Open the registry editor and find the following key:
HKEY_CURRENT_USER\SOFTWARE\Microsoft\Internet Explorer\MAIN\FeatureControl\FEATURE_BROWSER_EMULATION
In there there should be a list with application names including "3dsmax.exe" it should have a value of 10000. Can you confirm that?


(Philip3d) #5

@klaasnienhuis
I am running 3ds Max 2015 on Windows 8, yes. Under the registry "3dsmax.exe" has a value of 100000. I also logged into Sketchfab from Internet Explorer directly, but it doesn't change how the exporter behaves.

For now I am exporting using fbx and that is working fine.


(Klaasnienhuis) #6

Darn it. I'm unable to test that right now.


(Robbevlaeminck) #7

Yeah I have the same problem, is there any change already?


(Klaasnienhuis) #8

I'm looking into this. Might have something to do with the Edge browser on win10.


(Fingerindustries) #9

Same here - just a blank pop-up. Tried logging in with IE/Edge and no difference.
I am running the latest Max 2016 on Win 10 Pro w/latest updates

Cheers
Marcus


(Philip3d) #10

Oh, and it does work with Windows 8, I just checked (I meant to say Windows 10 earlier when reporting the problem)


(Klaasnienhuis) #11

Thanks for the info people, I've contacted the sketchfab team about this and we're working on a solution.


(Robbevlaeminck) #12

Thanks alot! It works for me, real heroes dont wear capes :smile:


#13

The newest version should now work on Windows 10: https://sketchfab.com/exporters/3dsmax

Thanks @klaasnienhuis !


(Wayne Tannian) #14

Had the same issue ..i solved this by ..deactivate my adblocker on fire fox browser ...clicked back on authorize and the accept button was active and i click all worked ...


#15

That's really weird because the plugin uses IE.


(Chiconc) #16

I have the same problem, Max 2014, and the plugin tries to open the IE 11, and only gives blank page, I´m using Win 7. Help...


(Darkage) #17

Hey guys, im using Win 7 and Mozilla Firefox with 3ds Max 2014. When trying to activate I get the same error but I do get a window hat pops up with the sketchfab login but I get a script error The SS is her http://puu.sh/myAb3.png
Is there something I can do to fix this issue ?

Regards
Damien


(Klaasnienhuis) #18

Hi @darkage ,
could you try restarting max and authorizing again? Authorizing only works correctly if max has been restarted once after this version of the exporter has been installed.
I just tried to authorize myself with max 2014 on win7 and it worked for me. It always uses IE by the way. That's the browser which is supported within 3dsMax.
Klaas


(Darkage) #19

Hi @klaasnienhuis I was able to get around it by linking my SF account with FB and then authorizing it through the FB part of the script. In regards to the base authorization ( I do not use IE) it would load up the login for SF but it would throw a scripting error on line 6 every time and whether I stopped or continued with the script it made no difference it would no longer proceed with the login button. But like I said all sorted now and thanks for replying


(Klaasnienhuis) #20

So, from within 3dsMax you initialize the authorization process by pressing the big orange button in the script. A window pops up. If you try to login with email and password you get the script error. If you try to login with facebook (from within the same window) it works. That is interesting, and also great you've found a proper workaround.