Unable to download bought 3D model

I bought a model from someone but the “Download” button in my Purchases page isn’t doing anything. I’ve checked my downloads and nothing is there, no downloads in progress, the button just doesn’t seem to work. It is lit up and clickable, but does nothing.

I’ve tried another browser with no success, and I’ve contacted the seller and I’m waiting for a response.

I would hate to have wasted $5 on a model I can’t even download.

I have exactly the same problem, just bought two models, can click on the download button, but nothing happens. I assume that when we buy something using this website, we dont have to debate with a seller…?!?

We’re looking into this now.

Hi, same problem here.

Could you fix it, please?

Tried multiple browsers.
Nothing happens when I click on download button.

cheers,
j

I found that only the “download”-button on the “purchases” page is broken. However, there is also a “download”-button on the asset’s page (a big red button), and that button works.

1 Like

We expect to ship a fix for this tomorrow. In the meantime, you should be able to download from the model page directly.