Unable to load Draft models in Screenshots from Sketchfab Experiments


I used to use the screenshots function of Sketchfab experiments for models that were still in “Draft” mode, not published.

I just noticed that I am able to load only published models via the URL search. Is this a bug, a problem or is it normal?

Same issue with video exporter.

Thanks in advance.

1 Like

I just checked and this works as expected for me. Make sure you’re logged in on the browser that you use for the screenshot, and that you don’t have some kind of super-strict cookie setting enabled.

1 Like

I’m having the same issue on my end. Tried multiple models that are on draft, no matter what it tells me that it “Cannot load URL”. I’ve turned off all blockers and cookie settings, still broken.

Please fix this, I use the screenshot tool a lot and I’ve tried this on two other browsers with the same problem.

Edit: I managed to get around this issue by going through my web history and copying the URL from an already loaded model, than changing the model code in it to the model that I want to screenshot. I noticed also when I hit screenshot it doesn’t display the model name like it used to, it just says “screenshot” so it seems it is a problem with reading the model name?

Thanks for the reports, we’re working on a fix.

Meanwhile, as @Plats showed you can still screenshot draf by composing URL yourself
on that url you would need to add the model uid at the end

Say draft model edit page is https://sketchfab.com/models/314623212c6e4b93acc623a01413a3d2/edit
the uid of the model is then
which gives
to be able to screenshot



it’s a bit tedious, but it keeps me working. Thanks again and I’m looking forward to the fix !! Have a nice day everyone!


It seems the trick with editing the URL for the draft model page no longer works. It simply doesn’t load the model on the page anymore and when I try inputting the draft model manually it’s still broken.

EDIT: Okay, it seems the old trick works but there can’t be a slash after the copied URL now. Previously it would still load with the / after it, but for some reason when it’s there that doesn’t work any more. I apologize for the thread resurrection.