" Unexpected upload error "


I’ve been experiencing this issue when trying to upload a new model. First time was two days ago and I managed to upload one hour later.
Today it’s also happening, it’s been around 3 hours and still not able to do this upload.

As it looks it could be a recurring issue, I decided to ask on the forum.

The file itself does not seem to be the issue as it does not work either for compressed files that were already successfully uploaded before.

Thanks in advance for any help,


Did you ever get this resolved? I seem to be getting “Unexpected upload error” when I try to upload an OBJ model in Firefox. Though I can upload fine in Chrome.

We have tracked down this issue and are working on a fix.

Thanks for the update, @abbyec !

This upload error is still current. When will the error be corrected?

Could you please tell me more about your particular upload error? Previously there had been an upload error when someone tried to upload an additional file archive before the model was set to downloadable. That has been resolved.

Currently there’s an error when attempting to upload Blender 3.0 .blend files. That should be resolved this week.

1 Like

@abbyec - I am having a similar issue using the following steps to reproduce:

  • Flatten multiple meshes in MeshLab

  • Export mesh as .OBJ Wavefront with combined .MTL

  • Create folder with merged .OBJ, .MTL and texture JPGs

  • Import folder contents into Sketchfab

  • Receive the “Unexpected upload error” prompt after the files upload.

  • Merged mesh, material, and texture imports back into Meshlab just fine.

Thanks for your help!


I am having the same issue when trying to upload .obj files or .stl files. .fbx seems to be working ok though.

@Cerberusguns @scan-everything please can you share a screengrab and/or a link to any failed model uploads if you still have them?

I’m also having the “unexpected upload error” for two separate files today, so I’m not sure what the issue is. One is an OBJ and the other is a PLY. Both are under the size limit and open in Blender and Meshlab. Here are the files: uploaderror - Google Drive

I’m having the “unexpected upload error” repeatedly today. I did manage to finally get the .DAE model uploaded, only for it to lose all of the texture information, leaving me with a blank model. I tried again using a ZIP file, only for the upload error to keep happening again. The file is well under the 50Mb limit for free accounts. When I open the model with Meshlab, it looks like it should. Here is the model: 1916 Cornice decoration.dae - Google Drive

1 Like

Same here. But when I downsize files to 50MB before zipping. The uploading status will be successful. btw my account is basic.

Facing the same issue, an unexpected error while uploading. I have to get this model up before my deadline. Please resolve!!

The “Upload error” notice comes since long time ( 2 weeks maybe or longer). if you check your uploads, there you can see that the models was uploaded well already with the error message.

Today I had a bunch of “Upload Error” shortly after giving OK to upload. All were OBJ+mlt+png/jpg. With verified geometries.
In some cases after an hour some of them have appeared in draft mode and I have been able to edit and publish them.
Others on the other hand have not appeared in drafts and at this moment all the attempts with all type of geometries and textures are giving me errors. All verified and all within the limits.

I’m also getting these “unexpected upload errors”, seemingly randomly - but the ones that errored still show up in drafts.

Thanks for these additional reports - we’re investigating the issue.

I’m getting this prompt again when trying to upload .ply files. Anyone else seeing this problem? It’s under the file size requirement.

This is my error. It is just a spinning ball. When you click on the link, it gives you a 404 error.

Hi there. Are you still running into this problem? I checked your account and you don’t seem to have any pending uploads anymore.