Sketchfab Forum

Unity 5.1.1. exporter is not working (FIXED! USER ERROR)


(Nekobolt) #1

Hi all!

I used to use the Sketchfab exporter with Unity 4 and it worked great, but after Unity 5 I've been unable to use the exporter successfully. I stopped trying for several months and now I attempted it again and still no go. I would really love to have my problem solved since the exporter is really convenient.

I downloaded the newest version of the exporter today (version 1.0.4) and it was created with Unity 5.1.1. so I also installed that version of Unity. I created a scene and popped in some of my FBX models. Then I selected some of the models and selected the "Export Selection to Sketchfab" from the Window menu. I filled in my API number and pressed "Upload to Sketchfab". After that the upload bar doesn't progress and nothing happens. My models are not uploaded to Sketchfab.

I get this error notice:
ArgumentException: An empty file name is not valid.
System.IO.FileSystemInfo.CheckPath (System.String path) (at /Users/builduser/buildslave/mono-runtime-and-classlibs/build/mcs/class/corlib/System.IO/FileSystemInfo.cs:255)
System.IO.FileInfo..ctor (System.String fileName) (at /Users/builduser/buildslave/mono-runtime-and-classlibs/build/mcs/class/corlib/System.IO/FileInfo.cs:58)
(wrapper remoting-invoke-with-check) System.IO.FileInfo:.ctor (string)
SketchfabExporter.export () (at Assets/External Tools/SketchfabExporter/SketchfabExporterWindow.cs:125)
SketchfabExporterWindow.export () (at Assets/External Tools/SketchfabExporter/SketchfabExporterWindow.cs:447)
SketchfabExporterWindow.OnGUI () (at Assets/External Tools/SketchfabExporter/SketchfabExporterWindow.cs:478)
System.Reflection.MonoMethod.Invoke (System.Object obj, BindingFlags invokeAttr, System.Reflection.Binder binder, System.Object[] parameters, System.Globalization.CultureInfo culture) (at /Users/builduser/buildslave/mono-runtime-and-classlibs/build/mcs/class/corlib/System.Reflection/MonoMethod.cs:222)

Please let me know if you have any ideas what is going wrong here.

Cheers,
Veera / Nekobolt


#2

Hi Veera,

The first line in the error message is "ArgumentException: An empty file name is not valid."

Can you make sure you save your scene/file first?

James


(Nekobolt) #3

Thanks for the reply and solution James!

This was a user error. I should have read the instructions properly, I was saving the project, but not the scene file and that was causing the problem facepalm.

Sorry about the noob mistake and thanks again for the solution, the exporter will save me so much time smile
Veera / Nekobolt

ps. Should I remove this thread or leave it for other people who might encounter this "problem"?


#4

Awesome! No problem smile

You can leave it here in case someone else has the same issue. Soon we hope to update the forum and implement a "Solved" features natively.