Unity export "zip file has not been generated. Aborting publish."

exporter
unity

(Pellemasi) #1

I'm very beginner at Unity (I know how to put my assets, materials and animations together but that's about it) and trying to upload my monster through Unity Sketchfab plugin but I keep getting this error and I don't really know what to do.


#2

I'm sorry you're having trouble. What version of Unity are you using?


(Pellemasi) #3

Unity 5.6.0f3


#4

Hmm ok. Can you open the console log and see if there is any more information in the warnings/errors?

https://docs.unity3d.com/Manual/Console.html


(Pellemasi) #5

Hmm.. I tried to get the error but now it seems to magically work..? I didn't even reboot my computer or do anything (just slept over night), and yesterday I tried rebooting Unity multiple times if that would have fixed the problem.

So thanks... I guess?
:smiley:


(Waleguene) #6

Hi @pellemasi,

Sometimes, the Unity editor is in a state where the exporter cannot perform some operations. It can be due to a lot of different reasons.
Closing and reopening Unity resets the scene and the editor to it's saved state, and most of the time it's ok for the exporter code.

It's kind of magical yes :slight_smile: but if it happens again, don't hesitate to open the console and post a screenshort or copy/paste the error logs so that we can identify the case and provide a fix if possible.

Thanks for reporting!