Unity -> Sketchfab - Texture tiling issue

feature-request

(Nekobolt) #1

Hi there!

I was trying to export a scene from Unity to Sketchfab and it all went well, but I noticed that some of my materials were a bit messed up. The problem is that I have set certain materials to tile x 2 or x 2.5 in Unity and this information seems to not transfer to Sketchfab. Am I doing something wrong or is this not supported by Sketchfab yet? Also do you have any tips for me how to best deal with this problem. My first thought was to manually make larger textures that have the texture tiling as much as I want, but that seems a bit MacGyverish. :smiley:

Thanks,
Veera


(Dark Minaz) #2

Texture tiling X anything is not supported (yet?)
so the only real solution is to go into photoshop, scale it to 50% and just tile 4 of them by hand. (for x2)


(Nekobolt) #3

Thanks for the reply dark_minaz!

That's too bad :frowning: Hopefully they will add support for tiling since I have a bunch of scenes that will not work well without it. Doing the tiling manually is easy with things that tile x2, x4, etc. but it gets tricky when the tiling should be something like x2.525, x3.111, etc.


(Dark Minaz) #4

I personally would do the tiling in substance and save it out as 1x1 texture.
Might help since you got x3.11 values.


fill layer, add the texture in the base color, set the uv scale to the value you want it and then hit export
Might be a workaround till then.


(Nekobolt) #5

Thanks for the tip! I will give that a try! :relaxed:


(Dark Minaz) #6

you are welcome, hope that helps until sketchfab adds a tiling function at some point.


#7

Feedback noted :smile:


(Duke Of Fancy Pants) #8

i know this is kinda late but it but it might help others.
if you try to get a tiling effect you can just scale the uvs more then the 1,1 uv space so for example if you try to get a 10 times tiling just scale your uvs 10 times


(Shaderbytes) #9

This is the preferred method since scaling textures down reduces quality of the texture. Scaling UV's up permits maximum texture quality when zooming close to the surface. In fact if sketchfab were to implement UV tiling in the editor this is what it would be doing in the background within the shader code :

pseudo code

uv.x *= UVXScalar;
uv.y *= UVYScalar;

(Buzzytrent90) #10

Hi all,

Apologies to dig up old threads! I am new to Sketchfab and super excited about learning this new sharing tool!

My materials in SketchFab do not seem to be correct, I am sure it is a tiling/uv scale issue. It seems @DukeOfFancyPants has mentioned a solution.

DukeOfFancyPants
Dec '16

i know this is kinda late but it but it might help others.
if you try to get a tiling effect you can just scale the uvs more then the 1,1 uv space so for example if you try to get a 10 times tiling just scale your uvs 10 times

Yet I am unable to work out how or where I need to scale the UVs. Do I scale them on photoshop or 3ds max (where I created the model and textures) or Unity or SketchFab.

My model and textures in Unity & exported to Sketchfab:

I've tried changing the UV & Tiling scales (currently 10x10 in 3dM) on 3ds max and then exporting from 3ds Max and Unity, to no avail.

Sorry for the long post!! Any help would be greatly appreciated.

Kind Regards from a fledgling 3d enthusiast


(Waleguene) #11

Hi @buzzytrent90,

Setting tiling/scales on UVs in 3ds Max texture setting will not fix your problem because there are no such options on Sketchfab and nothing is done on the mesh/texture data to reproduce the effect (so your setting is lost).

You have two solution: modify the image in Photoshop or modify the UVs in 3dsMax.
As mentionned by @shaderbytes, modifying the image is not the best solution because it reduces the quality of the texture.

It's better to scale the UVs in 3dsMax: if the mapping is simple (using UVMap modifier), you can use the UI to set a tiling factor:

Default tiling parameters:

Setting tiling on U and V to 3:

If your uvs are more complex (using Unwrap UVW modifier) you can manually scale/move your UVs to try to reproduce the effect:

I hope it helps,