Upgraded To Pro. Now: [Sketchfab Exporter] Network upload to Sketchfab failed with HTTP error: Connection closed

Hi,

As of last night around 11pm PDT to now, 4:00pm PDT, I have been unable to upload from Substance to Sketchfab, having just purchased my Pro account.

I just bought my Pro account because, tomorrow, I’m talking to a person about architectural galleries. Can’t upload the gallery in question we’re talking about.

“[Sketchfab Exporter] Network upload to Sketchfab failed with HTTP error: Connection closed”

I’ve tried:

  • Logging in and out of Sketchfab externally, and re-logging in when uploading.
  • Restarting Sketchfab/PC.
  • Shrinking some texture sizes, since I’m really at the edge of 200mb (I would really like more for a Pro account, by the way)

That’s the error. This has happened in the past and I’ve just had to wait for support to fix. Please advise.

Update: Been trying over and over because this is extremely important. I’m wondering, because the “processing payment” page never finished, though my account was upgraded and my Paypal charged. Now I cannot upload at all. I worry that something wasn’t processed properly and, weirdly, the result of upgrading my account has been to temporarily disable uploading to it.

Hi,

Sorry about this! Are you by chance on a slow connection? How long did it take to upload the 200mb?

We increased our upload timeouts. Could you please try again and let me know if it’s fixed now?

Hi,

I had to be away for a bit. Trying again now, just changed my password. My connection isn’t super fast but it’s not taking a long time. I’m not sure how long… less than 10 minutes anyway.

It seems to have gone up and is processing now, thanks, hopefully that did it.

Well, it went up, but one particular set of wall textures that have similar names were mixed up: TEX_WallsandDoorTrim were also assigned to the texture channels of TEX_walls. I re-assigned them and it seem to be all right now. I’ll check more in the morning.

1 Like

… Also I can’t seem to update it via Substance to make changes to it now. Doesn’t show on my list of existing models in the Substance UI, and I cannot find where you keep asset IDs. I’ve checked my model’s properties, the page, the 3d settings… Where is the asset ID?

In fact, when I check “Update existing model” it just assumes I mean the first one on the list, even though I didn’t select it. Kind of a poor function.

It’s not on the model page. It’s not in 3d settings. It’s not in more model information. It won’t show up on my Substance list when exporting.

So I took it out of the HTML bar, which works, but if this is literally an identification for an asset, put that front and center for your artists to see.

123123Capture

Gateway time out.

Okay… Trying to upload it again resulted in an error stating it’s already processing. No, it isn’t. The error above this one is the error I posted, above.
So it failed to upload, but seems to think it’s processing anyway now. It’s also taking a long time today. Not sure why.

wrongagainsketchfab

Even more weirdness. I tried uploading again - went up just fine. However, my wall that was having issues before was really, really dark. Nothing like the original’s colour.

Well… It inserted roughness as AO, for some reason, but only on that material.

evenmoreweirdness

It’s still weird! There are several issues…

I updated one of the UV maps and re-uploaded:

  1. Wall textures all mixed around again with a different wall texture, not attached, quite differently named.
  2. I thought, at first, something had majorly gone wrong with resolution, because my floor texture was displaying at roughly 256x256 despite it being 4k. The page was fully loaded, according to the blue bar. I reloaded, still same problem, exited the 3d editor and went back in… Yeah, it’s randomly removing texture channels, as far as I can tell.


WRONG.

Yet, I check the 3d editor:

So… Am I now rolling the dice for whether a potential client/customer can actually see my work? The wrong version pretty much makes me look like an amateur.

It’s different every time I reload it, but it’s only actually displaying properly rarely and only in the 3d settings.

Just a reminder: this was for a client on Tuesday. This is NOT working at all.


Didn’t change anything. The level of resolution on my textures, especially the floors, is different whenever I load the page. It’s basically ruining my work.

It’s wrong every single time, in some regard. Going to have to keep it on private. Sometimes it’s just missing materials completely.


^This one is actually okay! Too bad the upstairs is all blurry!

It’s okay in 3d settings. It’s blurry and messed up in the actual viewer. Nothing seems to fix it.

It’s all working great, with all 8k textures, in Unreal. No problem.

… It works now. When I loaded it in Chrome and flicked it from SD back to HD it loaded up just fine, so I opened up Firefox Nightly and it also worked just fine.

I don’t know what the issue was, but it’s working now. Maybe it just wasn’t switching over to HD in the viewer? I can see in one my pics it was on SD, but I was flicking it back and forth earlier to no effect. It could also be that the loading bar wasn’t displaying when switching over and therefore didn’t appear to be continuing to load. I had also left for a while and shut down when I did so.

So: yay! Haha =)