Upload Error: You have reached the private model limit of your plan


(Juanjocopovi) #1

I am getting the error above when uploading.

Trying to overcome the problem, I deleted a number of older private models but it does not seem to help.

What can I do to fix this?

Thanks,

Juanjo


(Tiagojdferreira) #2

Hi @juanjocopovi,

Thanks for reporting this problem, I passed it on to a fellow developer who will take a look at it. I'll keep you posted.

Cheers,

Tiago


#3

It looks like you've just used your private credits for this month. They will be reset next month, or you can upgrade to Premium.


(Juanjocopovi) #4

Thanks James, but this is the first time I hear of such a limit.

When was that put in place?


#5

About a month ago, you can read the announcement here:


(Juanjocopovi) #6

Thanks again James.

Being one of that 0.01% of users my operation was hit by such a change and that forced me to patch some of our code.

However, I am still getting problems when uploading animations even though I upload them as public models now. Same error but it only happens with animations and not with 3D models.

I am really getting trouble because of these unexpected changes and I will appreciate again your help on this.

Juanjo


#7

The change of plans should not have affected animations. Can you elaborate on the issue and send me a link?


(Juanjocopovi) #8

Sure, I am using your python API uploader to upload files. I do upload two types of files: (1) regular 3D models and (2) animations using mesh files and a sketchfab.timeframe file (all of them packed into a single zip file).

Just a moment ago I tried to upload a 8.1MB animation file that ended up with error:

$ ./send_sketchfab.py CocineroSuelo3,95md.zip ""
Upload failed with error: {u'detail': u'You have reached the private model limit of your plan'}

If I use the same upload command with a 3D mesh (STL or PLY or OBJ file) it just works as expected, no error is shown and upload is completed and successful.

All the time I am uploading public models using my PRO account. Here you have a link to that zip file https://we.tl/xnhmV4Yufa


#9

I could not reproduce this error. It looks to me like you really have just hit the limit.


(Juanjocopovi) #10

Hi James,

How is it possible that when uploading a PUBLIC file I get a message stating that I have reached my PRIVATE limit?

Yes, I have started this thread with that error message happening with me uploading PRIVATE models, but now I have switched to PUBLIC models and I am still getting that error. Which does not make sense to me.

What is even weirdest is that this only happens if the uploaded file is an animation.

And I do not understand when you say "I have just hit the limit"? Could you please elaborate on that? What is the limit you are talking about? (Please note I am just uploading public models from my PRO account (which according to https://sketchfab.com/plans ) has Unlimited uploads.


#11

Hmm, this sounds very strange. Can you share your upload script?


(Shaba1) #12

Please excuse my ingnorance. I am very new to sketchfab. I signed up years ago but never forgot that I had. What is a private model?


(Juanjocopovi) #13

(Juanjocopovi) #14

Sure, here you have my upload script (minus my token) https://pastebin.com/Cv7Fka0k


(Juanjocopovi) #15

Can you share your upload script?

Dear @james,
Did you have a chance to look at the upload script? (though I fail to see how that could be the culprit).

I understand there have been some holidays but we are trying to run a business too and part of our operation is now in trouble by something that apparently should not be happening.

Hmm, this sounds very strange.

Don't get me wrong, I feel you are investigating the case but since November 30th we are working overtime to fix problems caused by Sketchfab suddenly deciding to change the conditions of a service we have already paid for in full. And to add insult to the injury some things that are not being changed seem not to work for us (for reasons yet unknown, that could include our own fault). But given the fact it has already been 15 days investigating the problem we are all but happy.

Wishing you all the best for the New Year,

Juanjo


(Tribble42) #16

Hi,

I had a look at our backlog and all your uploads and failed upload attempts. It seems that every time you got this error, you were sending the private = 1 parameter in your payload. If you use this parameter, you ask Sketchfab to make your model private. As you've reached your monthly limit for private models, it is normal that you get this error.

As far as I see there isn't any problem.

Best,

Frederic


(Juanjocopovi) #17

Hi @tribble42,

I cannot rule out me being wrong but I doubt I am. The reason being that we only have one upload script (which I shared in this thread).

When I complained 12 days ago one animation was not being uploaded while the rest of the content was, all of them were public models. It could not have been other was as I was being told I have exhausted my credit for private models.

Given we only have one upload script, and that private models were not allowed, and that I was successfully uploading public models, but the animations I was uploading were rejected stating there was no more room for private models, I assumed the error should be on your side.

However, because I could not fix the problem, I came back to this support thread explaining the problems I was experiencing. I even supplied @james a sample animation whose upload was rejected, again with the same message about the limit of my private models (when only was uploading public models and animations).

Kind regards,

Juanjo


(Juanjocopovi) #18

Quick question, if private value is not provided by the upload script, do both 3D models and animations assume model uploaded is public?


(Juanjocopovi) #19

Dear @james,

I trusted your statement and given the month have changed I went back to attempting uploading private models. Just be greeted with the same message: You have reached the private model limit of your plan

But let's do another baby step, why do model http://sketchfab.com/models/e5b6568a2aa5400aa1bdd00dce066cc9 upload was rejected as a private model today (3rd Jan 2018)?

Thanks a lot,

Juanjo


#20

Sorry for the delay. Everyone was away for the holidays.

Looks like there may have been a problem with the private upload credits. I just reset yours to 20 for the month.