Uploaded mesh changes if there are materials or not

Hi!

I am having a weird problem uploading a mesh to Sketchfab.

I have a file that contains three objects. Each of these objects has one material. What I get is the following behavior:

if the file is imported WITH materials, the mesh comes out as distorted. If the file has no material information within it, the mesh comes out exactly as I see it locally in Blender.


The mesh here looks correct (no materials)


The mesh here is wrong (with materials)

Another problem happens on the same floor mesh, but on the opposite side, but I can’t upload more than two photos. A hole appears between the floor and the base of the two columns.

And the weird thing is that both files, with and without materials, are shown as exactly identical in Blender, when reimported. The thing is, they are, as they are exported exactly from the same mesh!

Things I have already tried:

  • using other export formats. I’ve tried glTF, FBX, OBJ. No difference, unfortunately.
  • using the Sketchfab exporter. Same issue appears there.
  • triangulating the meshes in Blender, before exporting them to Sketchfab. Same result happens.

Could anyone possibly help me with this issue? Here are the files (two .obj files, one with materials, one without):

withandwithoutmaterials.zip (36.6 KB)

Let me know if I should provide you with anything else, and thank you so much in advance for your assistance!

1 Like

Sorry to increase the weirdness factor. I’m able to reproduce the issue, but I’m having the issue both with and without materials when importing through the blender addon. I even removed the default obj materials on the sans material version.

With:
image

Without:
image

I wonder if it’s something compression related…

1 Like

On the opposite, thank you! And I’ve experienced the same. The only way to make it import correctly is by exporting the meshes to another format and purposefully exclude the materials from the export.

I’ve tried exporting the floor without an attached UV as well, but once again, the same problem appeared. Now I’m trying to see if it might related to normals? I don’t really know anymore what could cause it…

By the way, this is the source blend file I’ve used to create the obj above!

weirdbug.blend (1.4 MB)

1 Like

I went with the simplest solution, which worked without addressing the original problem: I modeled a new floor plane and this one doesn’t get deformed.

I really can’t tell why the original didn’t work, but I will bypass the problem…

EDIT: nevermind! It still happens, just a new deformation. Can this be a problem of… intersection?

Thank you for writing this. It was, I think, and it pointed me in the right direction. Specifically, this topic from 2015: Sketchfab messing up geometry on model that worked previously - #3 by thealterian

It was indeed, I think, Sketchfab’s uploader performing some compression and probably merging vertices in an unwanted way, probably because of the sparse geometry of the floor. I realized this was it as I tried to bring the plane a bit up on the Z axis, causing Sketchfab to completely destroy the three meshes.

Thus, following that topic’s solution, I have subdivided the plane, thus probably providing enough geometry for Sketchfab to properly process the plane. It worked!

1 Like