Uploading colored meshs to sketchfab


(Chrisslemke) #1

Hi there,

I have just gotten started using 3D models for my website and I'm facing various challenges.

The biggest one is, that I can't seem to upload colored meshs to sketchfab. No matter what format I export those from in meshlab, they always turn out in a greyscale.

Can you tell me what format or process I can use to get them in color?

That'd be of great help,

thank you

Chris


#2

Hi Chris,

What software are you using to create the models? Do they have textures? material colors? vertex colors?

Typically, uploading something like OBJ + MTL in a ZIP will preserve material information.


(Chrisslemke) #3

Hi James,

thank you for your reply. I'm using Meshlab.

Yes, my model has colors, see screenshot attached.


And now I've just uploaded and -obj and .mtl in a zip but what's turned out is rather colorless.


Archiv 2
by chrisslemke
on Sketchfab


#4

Did you use some 3d scanning software?

The MTL file references two textures, "tex_0.jpg" and "tex_1.jpg". Without them, there is nothing to display. You should include these with the OBJ and MTL.


(Chrisslemke) #5

Hi James,

thanks for your help.

Well I#ve used 123d for scanning and then I downloaded it and then made changes in meshlab. I think there were textures in the 123d download. Now there is the question how to extract the testures from meshlab.

Or do you recommend something else?

THanks again

best

Chris


#6

If you're seeing the colors in Meshlab, it already has the textures referenced correctly. They should come with the download from 123D. After you make your Meshlab changes, just find the original JPGs and move them into the new folder. Then ZIP and upload!


(Chrisslemke) #7

Hi James,

that was a good idea and I tried it immidiately (that's why I went pro). I took the .obj and the .mtu as well as the pictures and uploaded as zip. Unfortunately, my shoe is still colorless (https://sketchfab.com/models/9d019129a35a4c76b5acb4084ecfe585#share= )

Can you tell me what I'm doing wrong?

Best

Chris


#8

I just checked your files and it's very strange.

1) It looks like there's a zip file nested inside another zip file

2) There still aren't any textures included. There's only a 'photos' folder with your original photos.

The .MTL file references the textures "tex_0.jpg" and "tex_1.jpg". These must be included in the ZIP you upload.


(Chrisslemke) #9

Hi James,

thank you thank you thank you.

I fixed my issue by creating my zip out of the .obj, the .mtl and the two original textures files. So that's great and I'm making headway.

Say, I'm still working on my shoe and have learned that I can use background images. Is there a chance I can upload my own foto?

Best

Chris

Edit: Another this I can't get my head wrapped around is the fact that the orientation of my models isupside down. Even when I change it in the settings, it never makes it into "reality". You have an advice for that as well?


#10

Hi Chris,

Custom backgrounds: you'll need a Pro account ( https://sketchfab.com/plans )

Orientation: Try using the Take Screenshot button to save default position/orientation.

James


(Chrisslemke) #11

Hi James,

thanks again.

We are moving forward and keep uploading better and better models. Now since I'm a pro user I'd very much like to change the background, but couldn't find the function.

Can you help?

Regards from Germany

Chris


(Bart) #12

Here you go:


(Chrisslemke) #13

Hi Bart,

thank you for your answer. I've tried what you recommended but the system returned an error (see screenshot). Have I made a mistake? What kind of immages are recommended as backgrounds?

Best

Chris


#14

JPGs at 1920x1080 pixels should be fine.

Not sure about that error... @stephomi maybe?


(Chrisslemke) #15

Hi,

I increased the size to about 3000 px, and I get it to upload. But when it's uploaded, it's not showing up even though I pressed "Save settings" several times.

Any recommendations?

Best

Chris


#16

Try using the Take Screenshot button to save?

James


(Stephomi) #17

Hmm if you have an environment set, you need to uncheck the "replace background" in order to use the fixed backgrounds.
(Not sure if it was your problem though..)