Uploading Model Causes Blocky and Jagged Vertices

blender

(Black Fluffalo) #1

I’m at a loss on how to fix this and I can’t find an equivalent to this issue with the keywords I type into google or on this forum. The model looks smooth and as it should be in Blender.


When uploading it manually to Sketchfab, it becomes blocky, with some vertices stretched out. Could it possibly be from the use of shape keys? Do they cause exporting issues? It would be the only thing I’ve done differently compared to uploading my other models.

Edit: I’m messing with the model to see exactly where the problem lies. At first I removed the pose and the mouth shaping and everything returned to normal. Next I tried removed the shape key and kept the pose and it resulted in becoming blocky and stretching again. Also the same when I do the opposite.


(Tomatoheadstudio) #2

I see you uploaded directly from a Blend file.
Two questions:
Do you have a subdivision modifier applied?
Does your model have any n-gons?


(Tidiestflyer) #3

I would take note that using shape keys with modifiers dont work well in blender. Blender will even state that you cant apply a modifier on an object that has shape keys. This can further become problematic when you dont export the file to an fbx and instead use the blend file.

There has been an issue Ive run into with auto smoothing data in unity when I would directly try to import the blend file. Problems I would run into are that the smoothing data wouldn’t update, “unless” I exported it as an fbx. Then unity would recognize my changes. Also had issues with animation clips. Blender doesn’t split up animation clips the way you would expect them to unless you exported them as an fbx.

My Suggestion. Either ditch any modifiers your using or ditch the shape keys, then export it as an fbx.


(Black Fluffalo) #4

To answer Tomatoheadstudio, my model doesn’t have any ngons that I’m aware of when looking at it in wireframe mode and I went back to make sure I applied modifiers but I still get the same result. Even weirder, I noticed that when it glitches out, the textures refuse to load.

To Tidiestflyer, I decided to ditch the shape keys and edit the models face later manually once we figure out the problem. When exporting it as an fbx, the model is completely normal looking, but the textures refuse to load. Is there any options I need to check when exporting? Edit: I’m going to just manually import them. A little extra effort never hurt anyone. Thank you very much for the fix! I’m going to take a picture of the broken version for anyone who runs across this same problem in the future.


(Tidiestflyer) #5

What I like to do is I package up my textures in a folder with the fbx. then upload them to sketchfab


(Black Fluffalo) #6

Same. I put them in a compressed folder but alas, it didn’t automatically texture everything this time. No worries though!


(Compostthesecond) #7

I had a problem that looks similar turned out it was in the weight painting distribution in blender, didn’t see it in blender because the distortion turned the faces inside out and made them clear so didn’t see it until it was uploaded … hope this helps