UVed mesh deforms incorrectly

animation
3d

(Kristaps R) #1

Hello!

I have problem with morphing-

Model with UVs deforms incorrectly - https://skfb.ly/QtYE

but model with deleted UVs deforms correctly - https://skfb.ly/QtYt

I have tried changing UV layout even remodeling mesh all together, but when its UVed it deforms incorrectly.

In full model there there are tons of meshes like these, that are UVed, but they deform correctly.

Please help me find solution for this. I have tried everything.

Thanks,

Kristaps

Edit: Also i have tried this animation on Maya, Modo and Blender, they work fine on those.


(Shaderbytes) #2

Could you make you example models available for download so others can test the files for you as well?

thanks


(Kristaps R) #3

ok. I made them available for download.


(Shaderbytes) #4

ok I downloaded the model , imported into blender , deleted the uv channel , made sure I highlighted the basis key in the inspector , went into edit mode nd unwrapped the model and finally uploaded using the blender uploading addon and it works as expected :

i will test fbx next..


(Kristaps R) #5

Thank you for looking in to this issue. It seems i have fixed it somehow. Not sure what exectly fixed it, but i got it working. I marged problematic mesh with other meshes and then separate it again that seemed to have fixed it, mesh worked as expected with UVs. Issue came back when i applied separate material to the mesh. So i don't. Weird issue. Very random. But it seems it will be ok for now. Thanks again.


(Mrchlblng) #6

@KristapsR, @shaderbytes,

we actually have a processing bug. We seem to not handle correctly exported tangent space for morph geometries. We're working on a fix; in the meantime, to bypass the issue, you may upload the model without exporting tangent spaces. Sorry for the inconvenience.


(Kristaps R) #7

Thank you for response. I managed to get the mesh working.


(Mrchlblng) #8

@KristapsR glad you had a way to bypass the issue.
Note that the fix has been released. Please let us know if you have any other issues!


(Kristaps R) #9

Thank you very much! :slight_smile: Model is live and working well at https://sketchfab.com/models/7cacc2f64fe34f08b27e25cd95760c4f