Vertex Color Option Hidden


(Basaltenburg) #1

On some of my models there is no Vertex Color option in the 3d settings. Some of my materials have a tendency to display as a black diffuse, and disabling vertex color solved this on one of my models. I wanted to see if it fixed the others as well, but the option is hidden on these. Does this mean I exported them differently or is there a setting I should enable to see all options?

Thanks in advance for any help.


(Moroplogo) #2

What is the format of your model?
You can read this article : https://help.sketchfab.com/hc/en-us/articles/210765623-Vertex-Colors


(Basaltenburg) #3

I imported the model that displays the vertex colors option as an FBX into Substance Painter, the one that is not working was imported as OBJ if I recall correctly. I used the direct export option from Substance Painter for both of these models, I'm not sure what format is used there.


(Mrchlblng) #4

@basaltenburg the "Vertex color" widget will only be displayed in the editor when we processed some vertex color data in your scene. If it doesn't show up, it's either that we have an issue with some vertex color processing or that your export did not include the information.
Could you provide a link to the model having the issue so that we have a closer look?


#5

The built-in export in Substance Painter uses Collada, and should preserve vertex colors.