Viewer api different behavior annotations

Hi @here,

I’m building small apps on the viewer api, mostly making use of the annotations, and noticed some changes in behavior, first I noticed that the jump from annotation to annotation is now without movement and just now I noticed that the app doesn’t move to the first annotation in the app (which makes sense, considering). Here an example of such an app:

https://miekeroth.eu/apps/octopus_exterior.html

The lack of movement is a little bit annoying (because I think people still aren’t commonly aware it’s real time 3d they are looking at, but the fact that the app doesn’t jump towards the first annotation anymore is a bigger problem. Regarding that last one I think I can solve it using code, the first issue can’t be solved on my side I think.

Hi,

Thanks for the report,

1/ I’m not sure I understand, in the codeI see that you use the preventCameraAnimation and preventCameraMove, but the behaviour is not what you expected ?
Current code is on octopus app is

    document.getElementById('a0').addEventListener('click', function () {
      api.gotoAnnotation(0, { preventCameraAnimation: true, preventCameraMove: true });
    });

whre the behaviour of “with movement” would be

    document.getElementById('a0').addEventListener('click', function () {
      api.gotoAnnotation(0, { preventCameraAnimation: false, preventCameraMove: false });
    });

2/ “app doesn’t move to the first annotation”
Sorry, I don’t get it again. you would like the app to go to the first annotation at load time ?

1 Like

Hi Paul,

You are right, but strangely enough this behavior wasn’t initially present. But this one is solved :wink:
The other one is that if I click on the first annotation, in the tabs below, it doesn’t go to that annotation. Doesn’t matter which sequence I use.

solved that one too. really strange, because also that behavior wasn’t there before

We have a saying in the Netherlands: “no longer seeing the forest through the trees”. This was definitely the case here.

3 Likes