Viewer embeds in the forum have issues with going fullscreen


(Shaderbytes) #1

Hi All

I noticed some issues with the viewer when clicking to go full screen , but only here in the forum embeds. The viewer on the regular sketchfab model page does not have any problems.

Ive seen two thing happen now, first on the forum post concerning the public release on animations , when I clicked the embedded viewer to go full screen , it launched a new popup window , with a strange starting width and height and did not stop the current embedded from being active. In the new popup window had to click play to load it again and it could not be made to be full screen ( borderless ) from this popups full screen button.

The second issue I just have happen was now when viewing the thread of the death of Jar Jar for the SWC , The last embedded viewer for the final entry , when I clicked it to go full screen , the screen flashed for a bit and then the embedded viewer vanished. So it didnt go full screen and there was just a white space where the embedded viewer used to be

Im using desktop chrome browser windows 10 - 64 bit


(Paul Sketch) #2

Cannot reproduce here, on my win10 + chrome.
Maybe related to the GPU

Would help if you could you reproduce on other websites with webgl ?
check https://www.shadertoy.com/view/Ms2SD1 (fullscreen is bottom right shader viewer)
http://www.edankwan.com/experiments/smashing-mega-scene/ (this one try f11 for fullscreen toggle)


(Shaderbytes) #3

Hey Paul

I could not reproduce the issue again either after posting , I have a MSI GTX970 OC Edition GPU. Driver 359.06

What I am thinking about now is that I had viewed and stopped a few embeds in this thread that day.. basically all of them starting from the top, I wonder if this had something to do with it..


(Mauricesvay) #4

@shaderbytes @paul_sketch

The new popup that opens is a normal behavior. It happens when the viewer can not go fullscreen for one of these reasons:

  • the browser doesn't support fullscreen mode, like Safari on iOS
  • fullscreen mode is blocked by the user (fullscreen mode requires a special permission)
  • the embed code is missing the allowfullscreen parameter (code has been edited, not properly generated). Some sites automatically strip the part that allows fullscreen mode (tumblr for instance).

The second issue you are mentioning might be a bug. We'll check that.


(Mauricesvay) #5

The second issue seems to be related to the forum itself. When the viewer enters fullscreen, the forum seems to kill the embed.


(Bart) #6

Which browser did you test that in? It works correctly for me in Chrome.


(Shaderbytes) #7

Hey bart , it does happen in chrome , but not everytime. I mentioned earlier about wondering weather it had something to do with me having started at the top of the thread and start/stopped several embeds as I was reading the entire thread.

I just tested this theory now and did a screen capture an behold it did produce the error .. caught on film! hehe :wink:

I will upload the video somewhere and post the link. You will notice the first few worked as expected and when I got the the same one I had the error previously on .. it did it again. As you press full screen it kind of starts going into it and then escapes out of it and the embed vanishes on the thread. Although in this video what is different is that the vanished embed comes back again each time. I repeated it three times , regardless its still obviously buggy since it doesnt want to enter into full screen.

will send link shortly


(Shaderbytes) #8

here is the video showing the bug :

(EDIT: I didnt expect the link to be displayed as a video here in the post , its just on my server space and doesnt steam very well, progressive download , so just pause it and allow it to load or right click and save the video to your drive and play it afterwards )

http://www.shaderbytes.co.za/sketchfab/development/embed_error_on_forum.mp4


#9

( If you put a space before the link, it should just show the link )

https://sketchfab.com/models/442c548d94744641ba279ae94b5f45ec


(Shaderbytes) #10

thanks James that trick worked :wink: