Virtual reality, grey areas in top and button


(Lpdenmark) #1

Hey
I have a question about viewing models in virtual reality.

I think it´s a browser problem, but have you an easy way
to get rid of the grey area in top and button when you view
a model in VR?

I´m using an Iphone 5S

Safari gives grey areas in top and button, Chrome only in top area.

Thanks in advance for any help


(Bart) #2

Could you share a screenshot to illustrate the issue please? And if possible one or more URLs where this happens too.

Thanks!


(Lpdenmark) #3

Hey Bart
Thanks for your answer :slight_smile:
I´m shure it´s not a Sketchfab problem, it has to do with
the browser ( I´m using Safari, but it is similar with Chrome
and Mozilla)
Just wanted to know if anyone know a trick to avoid it, I´m new
to VR.
When you view a model in normal mode I can go fullscreen, but
in VR I get the grey areas in top and bottom, which reduce the size of the to images.

I can see the Sketchfab app can do it without the grey areas.

I upload a screenshot so you can se what I mean.

Thanks in advance


(Bart) #4

Ah! It's the 'browser chrome' that's showing. I don't see that on my iPhone - could you try rotating it to portrait and then back again? Does the chrome still show then?


(Lpdenmark) #5

I have tried everything, but can´t avoid it :slight_smile:
Iphone 5 S


#6

If you rotate to portrait, and back to landscape, it should hide the gray bars. This has always worked for me, maybe you need to update your version of iOS?


(Lpdenmark) #7

I´m running 10.2 , should be up to date :slight_smile:
Tried rotating many times, but it don´t work.

My client is running Iphone 6 and have the same problem, strange


#8

Sorry, I'm not sure what to tell you, it works here on all the devices I tried.

Soon, we will be launching our native iOS and Android apps, which won't have this browser-specific problem.


(Lpdenmark) #9

Hey James
Thank for you answer.

I can have it work now, and as expected it has something to do with the
way I´m activating VR, and I belive it´s caused by the browser.

If I activate the VR from a model interface I get the grey areas.
If i start to activate the orange VR symbol I get the models page
in VR, and if I activate a model from here it works alright.

I just have to do it the rigt way, but I think it´s a little bit complicated
to e-mail a link to a client and make shure he gets it the right way.


#10

Hmm, that's weird.

Does it work ok if you navigate directly to VR mode?

https://sketchfab.com/models/442c548d94744641ba279ae94b5f45ec/embed?cardboard=1&autostart=1


(Lpdenmark) #11

Hi James

If I cut and paste your link in an e-mail and send
it to myself, I get the grey areas when I click on the link
when I recieve the mail.
( I understand if you are a little frustrated :slight_smile: