Vive Pro Side-by-Side offset, left eye bleeds into right eye! Please help!

WebVR used to work perfectly in firefox, then suddenly the left eye’s image is partially visible in the right eye, and both eyes look very distorted.

What happened??? Is it on my end? Did a SteamVR update cause this? Or maybe a firefox update?

Please help!


thanks for the report, could you provide the VR device you have the bug on ?
(rift, Vive, etc.)

It’s a Vive pro, and thanks for the fast response.

Just some updates:
I get same problem regardless if using FireFox 67 or FireFox nightly 69,
I get same problem regardless if using SteamVR or SteamVR beta 1.5.11,

And I was not able to get any other browser to work with WebXR and Steam, so i could not verify Chrome or Servo as they failed to even recognize the HMD.

I am running Win10, I9-9900k, Two 2080-TI gpus, SteamVR and a vive-pro

thanks, I didn’t not succeed to reproduce the bug.
(but only have a vive here, not at vive pro)

Could you try adding url parameters to the webpage in order to see if it helps?

Chibi Raxaldion - 3D model by zcythe (@zcythe) - Sketchfab

Chibi Raxaldion - 3D model by zcythe (@zcythe) - Sketchfab

Chibi Raxaldion - 3D model by zcythe (@zcythe) - Sketchfab

Just tried all three links you provided and the result is exactly the same for each.

I have no clue which part is failing, it might be SteamVR, it might be FireFox webVR, or it might be Sketchfab - but none of them allow me to downgrade to previous versions, so I’m completely stuck, alone, just shooting in the dark and holding my breath.

Just tried complete uninstall/reinstall of SteamVR, did not help…

Just completely uninstalled/reinstalled firefox, also deleted it’s prefs.js and reset all addons, did not help…

Not sure if this means anything but when i press the “View In Vr” button I see this error gets logged to the console:

"Error: WebGL warning: drawElements: Drawing to a destination rect smaller than the viewport rect. (This warning will only be given once)"

SteamVR just updated to 1.5.13, did not help…

Does anyone have a Vive Pro to confirm this issue?

I can’t use the site anymore. This sucks!

Just updated FireFox nightly to 69.0a1 (2019-06-21), did not help…

I think I found something very interesting.

Using an older vive I tried turning up it’s resolution and I see it does exactly the same thing as the vive pro!! Maybe this will provide proof of the issue:

Image created using a Vive classic (increased resolution to 200%).

I fixed the Vive Pro!!! :slight_smile:

You must turn down the resolution to no more than 68% (2036x2260) then the Vive pro looks okay again:

Image created using a Vive Pro (reduced resolution to 68%)

Any higher than 68% and the cross-eyed effect starts to become noticeable again.

I still don’t think this is the best solution because the resolution is now reduced. But I just hope this gives the Sketchfab team some kind of hint on where to look for the problem.

Please fix the Vive Pro!!

same problem for me, using the Vive Pro,
i hope it gets sorted out because getting the Valve Index next week
with better resolution! Dont want to tune down resolution.

Thanks for the detailed repro, it helps a lot!
If I could have more details it would help finding a solution:

  • could you go ( while inside VR )and get the values given ? (Device Aspect-Ratio is interesting, but best be safe and get them all)
  • how do you “turn down the resolution” so that I can try (in my case “turn up the resolution” in order to repro)

I thought I made that pretty clear, I even added multiple pictures showing where to adjust the resolution.

It’s done in SteamVR. Look for: settings > Application > Custom Resolution (as shown above).

Just adjust the slider to a higher res, that’s it. When the slider is up far enough then Sketchfab breaks. At 200% even the legacy Vive appears to act exactly the same as the Vive pro and shows major overlap/offsets.

Please see the SteamVR settings, and please see the two images I posted above.

Thanks, strangely saw only the 1st picture on 1st post of the thread.
Thanks again, I have now what I need to reproduce and check for a fix


Whats the status on this issue? We are also experiance this when trying to get Sketchfab up and running on HTC vive pro.

1 Like

We reproduced the issue and working on a fix

We released the fix, could you check on your side if it works on your hardware ?


I seem to be getting a similar issue with the Samsung Odyssey (original). Each eye is distorted as if cross-eyed.


We don’t have any samsung headset here, so it won’t be easy to reproduce.
It would help a lot if you could test & reproduce the “steam custom resolution fix” Vive Pro Side-by-Side offset, left eye bleeds into right eye! Please help! and see if if fixes for you, and particularly at which resolution the bug appears

1 Like

sorry to be that late, but it VR works now with the Valve Index! Thank you

1 Like