VR display problems

vr

(Mosheca) #1

Hi. I recently purchased VR goggles to view my (and other) models. However, for an unexplained reason when I move to the VR mode the model disappears from view and I can not get it back. Reverting to the default 3D view brings it back. Any suggestions ?
Many thanks.


Help needed with VR
(Bart) #2

Hmm, which headset are you using?


(Mosheca) #3

Hi. Actually I have two headsets. First I bought The Google Cardboard, then I upgraded to the DESTEK 2016 . But the problem is not there. As soon as I click on the VR button in the SketchFab viewer, the object veers off screen. Sometimes I manage to find it by twirling around, however, as soon as I touch it on the screen it immediately zooms in and disappears.


(Bart) #4

Does that happen on all models, or on specific ones? If so, could you share their links?


(Jshirkucla) #5

This is happening for me as well, for all models, including those from other Sketchfab contributors. Before, I was able to see the model in the center of the screen with the ability to rotate around it by turning my head. Now, I am only able to see it from one angle and when I turn the model goes out of the field of view. It is almost as if I am stuck in 1st person mode instead of orbit. I'm using a Google Cardboard headset.


(Alban) #6

This is due to the introduction of our new FPS support in VR mode. You can still get the orbit mode, for this you need to click on FPS and then Orbit in the navigation options. Now that we've shipped FPS support, we'll revert back to orbit as default soon (hopefully next week). We are still iterating on the best ways to navigate Sketchfab content in VR, which differs wether you are looking at an object or a scene.


(Jshirkucla) #7

I am viewing an object, a .stl file. The default for me still shows as Orbit. However, when I switch to First Person, then back to Orbit, I am able to orbit the image similar to the way I could before. But, the axis of rotation seems to be far from the center of my object. So I am very close to the object at some points during viewing and very far away during others. When viewing my model not in VR mode, I can confirm that the axis is at the center of the object. Is there a way to remedy this, or even to revert to the prior orbit settings? Thanks in advance for the help.


(Alban) #8

We are reverting to the priori orbit settings.


(Jshirkucla) #9

Thanks! Any chance if you know when that will take place? I only ask because I am doing a presentation Monday with some models I have created and can't use the current settings.


(Alban) #10

Soonest would be next Tuesday or Wednesday. You can always reposition the rotation axis by panning the model, so you should still be able to use it for your presentation, even though it's a bit less convenient for now (sorry about that!)


(Solomontechnologylabs) #11

Any progress on the "Default" First Person problem? It appears that even if the "Orbit" mode is selected after the first person has launched, the model does not automatically revert back to Orbit, even if the button is selected again. You have to keep selecting it and reverting back to the main page in order to get out of first person mode. I would surmise that the greater majority of people just want their model displayed in all directions and the "game" mode (first person) would have a fewer volume of people requesting that. As I have read, many developers/artists of their 3D models, just want to show them off and it's a "Real Downer" when you always have to finagle with the controls for a significant period of time and by the time you get it working, the "WOW" factor is lost . . . I vote for making the Orbit mode smoother, faster, and have some way of initializing the model in VR mode to a particular view. But to revert back to the default view when you minimize the image and come out of VR Mode.


(Mosheca) #12

I second that. At present the VR solution just does not work well enough, and that's a pity because when it does it's fantastic.


(Jshirkucla) #13

Agree with above. The prior settings for orbit mode were fantastic. I was using this daily for work but have had to put everything on hold for the last few weeks. Hoping this can be remedied soon.


(Cedric) #14

Hi,

Agree, we are aware of this and we will improve the VR navigation soon.


(Alban) #15

So we just reverted it to how it was before.


(Solomontechnologylabs) #16

OUTSTANDING! :facepunch:


(Solomontechnologylabs) #17

There is a bug in the code for displaying the "Annotations" in VR Mode. It appears that the annotations do not align with their original corresponding positions in VR mode. They remain in the same position (orientations) that they were in when displayed in "Normal" mode. If I may suggest, that you automatically disable the annotations in VR mode (default) as soon as that mode is selected, the image is zoomed and the phone is rotated into landscape orientation. This will not spoil the overall impression of being in a Virtual environment until this bug is eliminated. It may take some time to fix, and I'm sure you agree that your users of this service do not need to apologize to their viewers as to why the numerals are floating "helter skelter" amid the actual model. I surmise this is a simple bug to fix, it only needed someone to point it out. Our application is scientific visualization and Sketchfab is a cost effective and wonderful portal to get our scientists to understand complex biometric data.