VR freezing on Safari and iphone


(Aaronopenshaw) #1

Hi Sketchfab,

In the last couple of days Sketchfab is freezing within a couple of seconds of entering VR mode. I am using an iPhone and Safari.

On my same phone Chrome still works in VR mode but is useless because the URL top bar remains in VR mode.

On my iPad Air VR mode works fine on Safari.


(Hk89) #2

Hi! I've the same problem. The file was working fine on Friday morning (central European time). But since Friday afternoon it started stucking after a couple of seconds in safari (iPhone 7).


(Desertlizzy) #3

Me too, on two different iPhones. Was working fine up to the other day then sticks after a couple of seconds. Once it popped up a window on the scene to put the phone in Google Cardboard; most of the time it doesn't get that far. Mobile Safari ends up crashing after a minute or two after being stuck. However, in iOS Chrome on the same phone, everything works fine.

Mobile Safari info:Mozilla/5.0 (iPhone; CPU iPhone OS 10_2_1 like Mac OS X) AppleWebKit/602.4.6 (KHTML, like Gecko) Version/10.0 Mobile/14D27 Safari/602.1

iOS Chrome info: Mozilla/5.0 (iPhone; CPU iPhone OS 10_2_1 like Mac OS X) AppleWebKit/602.1.50 (KHTML, like Gecko) CriOS/56.0.2924.79 Mobile/14D27 Safari/602.1


(Hydrographer) #4

Hi, same problem. Two different iPhones (6), both tested over wifi and 4G. Tested different models. The problem arose friday afternoon CET. Not just the model but the entire browser freezes.


(Rémy Bouquet) #5

Hello,
thanks for reporting.
We are currently investigating this issue.


(Desertlizzy) #6

Thank you. The regular model works just fine (I can pan and zoom around) on Safari Mobile. It is only if I hit the VR icon. It seems to be crashing on accessing the iPhone accelerometers. The VR model (2 views) loads OK and the positioning target animation occurs, there is a slight judder in the positioning target as it responds to the iPhone position, then it locks up.


(Rémy Bouquet) #7

Hello, this issue should now be fixed.


(Hydrographer) #8

I can confirm, thank you.


(Aaronopenshaw) #9

Yes thank you. All looking good.


(Desertlizzy) #10

Thank you, it is working for me now on Safari Mobile.


(Michaelduva) #11

Any folks having this issue again ? i cant get a model to load anymore even tried chrome on my iPhone and clearing cache


(Aaronopenshaw) #12

Just tested one of my models and everything is working fine.

Cheers, A


(Michaelduva) #13

thanks Aaron !!


(Mikechorost) #15

But it doesn’t seem to be fixed. I’m using the Sketchfab app on my iPhone X, and it just shows the traveling “loading” line against a blurred-out image of the object I’m trying to view in VR.