VR in Safari, Chrome not working

website
vr
viewer

(Jshirkucla) #1

Have been having issues with the VR in both safari and chrome since the release of the new viewer. The model will open, then when I click on the VR icon nothing happens. I use this daily and it's frustrating to cancel meetings with customers when it is not functional. Any idea when this will be fixed?


#2

Thanks for the report! We're investigating.

As a temporary solution, you can navigate directly to {model_url}/embed?cardboard=1&autostart=1


(Jshirkucla) #3

Thanks James...the workaround you sent works great!


(Jshirkucla) #4

The VR link is fixed (thanks!). However, models with wireframe overlays do not appear to render correctly. When the models load in VR, the wireframe disappears.


(Vrheart) #5

My models which worked in VR a few weeks ago, aren't working any more. Orbit mode isn't working- the angle at which the model sits doesn't change with head movement and bizarrely the model is up in the sky. I'm not sure if this is the same issue jshrkucla experienced.


(Vrheart) #6

And this appears to be the case for all models including sketchfab recommended demos like the elephant

elephant by boriscargo on Sketchfab


Orbit mode doesn't work in Safari or Chrome (iphone 6)

(Jshirkucla) #7

I'm now having the same issues. This happened several months ago too. You have to switch out of orbit to first person, then back to orbit. This sort of works, but your axis of rotation will probably be off. The wireframe issue is still not fixed. It seems that there are multiple issues with the viewer that I hope are resolved soon.


#8

We're experimenting with "teleportation" as the new VR navigation behavior. There are some things to fix, but this is the idea:

  • It will be possible to set a scale (e.g. looking at an object vs standing in a room) The default is a 1 meter size object floating at eye level.
  • There is a grid on the ground. Looking at the grid and pressing the cardboard button will teleport you to that position. The indicator on the ground is a black square right now, which is a bug.

(Bblakesley) #9

Ah man. I thought the grid was showing because I had some weird scaling going on with a new scene I'm testing. Once I saw this post I went back and most of my VR scenes won't load now. I've got a big client meeting on Wed. I was trying to get ready for. I'm screwed.


(Vrheart) #10

Thanks James. I also was planning to show some virtual reality heart models at a medical conference this week. Can't you revert to the old way? It worked really well.


#11

@bblakesley - Sorry, what do you mean "won't load now"? Everything ~should~ load as before, only navigation has changed.

@vrheart - We're not planning to revert, but we are rapidly iterating. Perhaps there will be an option for the old Orbit mode in the future.


(Vrheart) #12

I would definitely recommend reinstating the old orbit mode in the future (very near future). For example, old orbit mode, new mode, first person mode as option. I was planning to recommend sketchfab for sharing medical 3d models (for surgical planning, education etc) but unfortunately I can't recommend the current VR navigation.

Here's a medical model in Sketchfab

PDA by vrheart on Sketchfab


(Bblakesley) #13

I replied to this via email - sorry.

James,
Please go to this link. https://sketchfab.com/models/246576050a644cb4ae16840922385e39 - and click the VR link. I'm using an iPhone 6 plus with the latest OS. The "Loading 3D Model" progress bar never finishes and it doesn't load.
I can provide further details on other files etc. if you can reproduce the error and need further info.
Thanks.


#14

Thanks. I just tested on an iPhone 6 with iOS 9.3.2. I reproduced the issue once, but refreshing the page fixed it. I tried the model page, the embed page, and the VR embed page on both Chrome and Safari, and they all worked.

If the issue persists, can you use Safari's remote debug tool to get the Console output from your phone?

  • Connect your phone to a Mac
  • Open Safari on both machines
  • Open the model page on the phone
  • Go to Develop > name of your iPhone > name of the page (you might need to refresh the page on the phone for it to appear)
  • Go to the Console tab, refresh again, and see what errors there are

(Bblakesley) #15

Sorry for late reply - it seems I didn't send correctly.

Thanks for the update James. The model now loads correctly. Obviously, you can't get the camera position in the right place so its still unusable. I'll have to wait for the added functionality you detailed in your VR post.


(Bblakesley) #16

If it helps others looking at this thread, I got a great tip from another user on this thread -- Cardboard VR camera positioning - https://forum.sketchfab.com/t/vr-in-safari-chrome-not-working/8965/13


(Bblakesley) #17

Sorry - thread is here.


(Jon Russell) #18

For some reason VR does not seem to be working with Chrome again, was there a recent change made by SF?


(Stephomi) #19

Most VR changes are coming from the browser themselves.

Which version of chrome are you talking about? mobile or desktop?
If it's desktop, you should now use the Chrome canary version.


(Jon Russell) #20

Thanks, I will check it out and get back to you if it still does not work (I am guessing it will).