VR Issue: scaling model moves it out of view, if not placed on floor


(Aleahy) #1

Hi, using the VR Settings we can shift the floor down so an object model is displayed at chest/eye height.

This makes for comfortable viewing of objects that would normally sit on a plinth.

However, when in VR if we use the wand control to dynamically change the "scale" this also MOVES the model. Scaling up the scene moves the model out of view!! While scaling down lowers it down to the floor.

This isn't what the viewer expects to happen.

The only workaround (if you want to experience the model with scale adjusting) is to place the model at 0m and leave it on the floor. This makes for crappy start experience with the initial model at 1:1 scale but now on the floor.

Our current workaround is to duplicate the model one with "plinth height 1:1 scale" and another with "floor model".

A better option would be possibly be to have the model 'floor' always be set to whatever offset was defined in the 'VR tab' regardless of scale. So if the "model is at 1.2m" any scaling is centered on that, rather than the 0m floor.

Alternatively being able to "fly around in the scene" not just teleport horizontally would also work... could be pukesville.

Actually, now that I write this, another workaround would be to add floor geometry to the scene and have the user teleport onto that rather than the grid floor. This is okay for scenes we have control over.

Andrew