Weaponry models' issues with meshes and polygons

Greetings everyone. Recently I ran into several problems with downloadable weaponry models. Firstly, all of them appeared to be over-triangulated, which may increase number of unnecessary polygons. What causes it and if there is a way of automatically fixing it? Secondly, those models have “diagonal shadows” problems there, where they must not be according to preview. Maybe it’s normals problem, I’m not sure.
P.S. I’m sorry if the questions I ask already were asked here, but I’m kinda rookie for this site so I apologize. If anyone’s wondering - I made an example from "Torn AK-12 mode"l by Lagzor.

It depends on how did the mesh got exported. If they applied triangulation on export or not.
Not sure about Blender, but in 3Ds max there is a “Quad Mesh” option, it does its best to make it quad again, but it’s hit and miss. Usually you need to fix up the mesh after.

Did you apply normal map to the mesh? I can’t tell from the picture, but it looks like the mesh got retopo to have a lower polygon count and baked normal map from high poly model.

I don’t know how much you know about normal mapping, but here is something to start with.

or this one


I just checked the model on Sketchfab, this is how it looks with and without normal map applied.

1 Like

Use ALT+J this option in Blender will change tringals to quads, but check UV, because there are some uv bugs on the uv map, especially at the edges of map.


Got it, thanks for the tip!

So I guess normal texture hides all those anomalies? That explains alot. But anyways I wonder why didn’t creator fix those? Is there a way to fixing that kind of errors in general, what do you think?

Its not an error. It’s a method to save PC resources, especially for real time renders. For example: video games.

They may look like anomalies, but they aren’t. The appearance is as a result of the face normals being interpolated (the edges are softened). If the edges weren’t softened, you would see the hard edges of the low poly even after the normal map is applied.

1 Like

Yeah, I get it now, but I noticed another thing - this model (along with others) is having lots of overlapping vertices. Is this a result of optimization as well?

Which ones are you talking about? Could you make an image?
As far as overlapping or floating verts go, its a normal thing in real time renders. Usually its better to have overlapping polygons to save resources.
Its as simple as “if it looks good, it will be ok”

Here is the screenshot. All parts of the model have overlapping vertices, most of them have 2 vertex in a single spot. Sure it doesn’t make anything look bad, but sometimes it may cause some troubles with exporting into game engines, for example. I know those vertices might be fixed with setting vertex weld thereshold to 0.001, but it might lead to some unpleasant result.

Oh yeah. Hmmm, it does look strange :thinking:
Not sure why, but it looks like *.dae mesh gets broken up. This leads to disconnected verts and you see them as overlapping double verts.

It looks like it splits the mesh on the UVs. So basically, the mesh polygons will be detached the way it was unwrapped. No clue how to import it as a whole mesh, but I would fix it by selecting all of the verts and welding them on 0.001 scale. It should be fine.

I know Substance Painter likes to export DAE file to Sketchfab. Maybe its just the way Painter works.

1 Like