WebVR controller / positional tracking issues


(Anatomy Dundee) #1

Hi,

I’m having an issue with Sketchfab on my Vive I wondered if there is a wider issue afoot, or if it’s just me? It was fine a couple of days ago, although the computer updated as it shut down, so I’m wondering if this is linked to the latest windows 10 update? At first today the Vive wouldn’t view firefox/Sketchfab vr at all (it works fine in steam and apps), saying ‘firefox is unresponsive’ and displaying a loading screen. I restarted and it now loads the models (although sometimes I have to click it a couple of times as it still says unresponsive at first), however, the tracking seems to be way out as my head it in the floor and the controller up in the air. Normally if I touch the touchpad it will rescale me but not anymore…(and the tracking is fine in steam)

I’ve update to the new version of Firefox – ‘Quantum’ which made no difference. I can ask our IT (I’m at a Uni) to take a look but thought I’d check first in case there is a known issue. Anyone else having similar problems or know of a fix? Thanks in advance


Position tracking not working in VR
VR view whats happened
WebVR not working?
Problems navigating VR in Firefox with HTC Vive
Control with oculus touch do not work well
(Andgokevin) #2

Yeah, I am noting the same issue with the height issues in both Firefox / Supermedium.


(Zimimi Z) #3

I also have problems, but on rift. First day I tried using my oculus to view sketchfab in vr mode it worked perfectly. But now when I try it doesn’t work as intended. First time I click on vr button I can see on my normal screen that the headtracking works fine and it looks right, but it doesn’t load into my headset. If I turn off vr mode and then turn it on again it loads up in my headset. But I’m on the ground and when I try to change scale I’m still on the ground but I can see the grid on the ground change scale. Any help?


(Andgokevin) #4

Yeah, to clarify, have the issues on both Vive & Rift as well. It worked well a couple of days ago.


(Rémy Bouquet) #5

There has been a recent changes on how we handle VR initialisation. It’s been done to avoid steam and oculus to start whenever you open a sketchfab model page even when you are not in VR.
I’m gonna work on a solution.


(Anatomy Dundee) #6

Thanks - it’s a relief to hear it’s not just me:-)


(Rémy Bouquet) #7

I found the issue and it should be fixed in a couple of days


(Aleahy) #8

Hi, same problem here, was about to post myself!

Suggest renaming this Topic to “Bug: VR stage is offset when launching WebVR”

Andrew


(Shanylazar) #9

Thanks nehon,

Seems this issue has extended further to Google VR on android as well.

a few days ago, when pressing the VR icon, it went straight to “real” google VR services. Now it just displayed as 2 images in the browser, with high latency and no lens distortion correction and no Gear icon to setup VR.

There was an update to Google VR services, tried to uninstall it, same issue.

Shany


#10

We just shipped a fix so this should be ok now.


(Xmt) #11

Still tracking rotate only and not translate, so I can look around but if I move everything moves with me. I’m using Windows Mixed Reality with Edge browser and this worked perfectly a couple of weeks or so ago. Full tracking is still working in other apps.


(Zimimi Z) #12

Yes no position tracking, it only updates headset position when you teleport, not when you look around.


(Shanylazar) #13

Thanks james.

When will the fix take effect? still does not initialize Google VR services correctly.

Shany


(Aleahy) #14

yup this is still broken (Sun 4 Mar 2018)
Bad staging, only pose tracking, no translation tracking.

Win10/Firefox Nightly/HTC Vive.


(Diogofigueiredo) #15

Apparently it IS tracking position, but scales are absolutely off. Initially my controllers appear flying 10 meters above my head, and positional tracking seems frozen, but if I change scales all the way UP until the controllers come back to the right place, then positional tracking works perfectly, but the models are gigantic. If I continue increasing the scale, positional tracking starts getting exaggerated (I move my head 20 cm to the side, but my virtual head moves 2 meters, for example).
I hope this helps.


(U Double U) #16

Hi,
I do have the same issue (tracking, scaling of the controllers off) and am asking myself (and you), why was it changed in the first place, when it was obviously running two weeks ago.
It was such a great experience.
Hope it will really get fixed.
Cheers


VR view whats happened
WebVR not working?
Problems navigating VR in Firefox with HTC Vive
(Leesm) #17

Hi, I use sketchfab for chemical education. Since a couple of weeks ago, the VIVE tracking on Sketchfab is totally off. Is there any progress on the fix?


(Shanylazar) #18

Hi, As of this morning, SOLVED for daydream and cardboard.
Thank you james!


(Andgokevin) #19

Yeah, the Vive is still broken though…We’re currently featuring Sketchfab content on our browser and directories, but we might have to temporarily remove those listings.


(Lestersculpt) #20

Vr controllers are suspended above me but still track. The model moves with me when I attempt to walk around it.