WebVR controller / positional tracking issues

(Diabuz64) #70

It’s good news, I’m sure the patch will work

Thank you.

(Diabuz64) #71

Has the fix been applied ?

I just tried and it does not work, the camera is still too high.

(Anatomy Dundee) #72

I just checked too and still issues our end. A slight difference to before is that they (for some models at least) load almost correct, only I am floating a just a few feet above the floor. But then if I press anything to teleport or scale I find myself way above it as before.

(Anatomy Dundee) #73

I should add that when first loaded and in almost the correct position, the positional tracking is working, so that’s an improvement. The controller is also visualised in my hand correctly.


Sorry we ran into some delays and the fixes have not yet gone into production. I’m afraid it will have to wait till next week. The French team is off on Easter Monday, so it might not be live until Tuesday or Wednesday.

Thanks for your patience.

(Diabuz64) #75

I found a manipulation that works perfectly when the camera is too high. It works even you only see a distant circle without seeing the model.

I place the cursor on the ground and press the right Oculus controller trigger. I move the stick to the left to get closer to the ground for 2 seconds. I repeat the manipulation until I am at the right height.

This solution works at 100%, I can make a video if you want it.

Vr headset and controller position very high above the position it's supposed to be. (HTC Vive)
(Diabuz64) #76

I do not know if it’s a bug but some human model have half of the body pressed into the ground in vr mode. Half of the body is under the ground.

(Zimimi Z) #77

That doesn’t always work perfect. If you do that with some models it feels like you are not standing on the ground and the model is huge.

(Diabuz64) #78

What is the model where you are not standing on the floor ?

The proportions may be too big but in the meantime it solves the problem of the camera above the model. There is another trick given here.

(Zimimi Z) #79

It works now! Great job! :heart_eyes:


Yep! The problems should be resolved now. Thanks everyone for your patience.

(Xmt) #81

I’m still having problems with the initial position, with the viewpoint sometimes starting high up in the air and a long way from the object. I also note that when cycling through annotations, the viewpoint is different if I use the ‘K’ key compared with use of the menu, though this may be a seperate issue.

(Diabuz64) #82

I do not know if it’s a bug but some human model have half of the body pressed into the ground in vr mode. Half of the body is under the ground.


@XMT Can you please share the model link and tell me what VR setup you’re using?

(Diogofigueiredo) #84

It’s working flawlessly for me now. Thanks a lot for the effort.

(Xmt) #85

The view point is set on the lip of the snail shell (it’s a big snail). I’m using Windows Mixed Reality with Edge browser. If I use Chrome, I just get a side-by-side image in the browser and the view point is correct. Edge on another computer without WMR does the same thing, it’s only the immersive view in WMR that is wrong.

(Mkhoward) #86

I believe you have to start the SteamVR service first if you want to use Chrome. It will see that running and send the content to the WMR headset. Same with any other source that is not Microsoft specific.

(Anatomy Dundee) #87

Just to report that it is working perfectly on our end now, thanks for much for your work on this!

(Xmt) #88

I don’t have Steam installed at work as Edge works directly with Windows Mixed Reality. I’ll try that at home (where I have Steam) and see if it is any different.

(Andgokevin) #89

Now that it’s up, you can seamlessly browse Sketchfab models through our virtual reality browser: http://store.steampowered.com/app/803010/Supermedium/

We’re featuring lots of Sketchfab content there, can visit hundreds of Sketchfab environments without leaving the headset. Also links to Sketchfab’s own VR index page. Hopefully will drive people to view people’s environment actually in a VR headset!