WebVR controller / positional tracking issues


(Diabuz64) #21

This topic might interest you. Control with oculus touch do not work well


(Aleahy) #22

yup currently a known bug.

See Bug: VR stage is offset when launching WebVR


(Bishopsfinger) #23

Ok Been using the VR view on sketchfab for about six months and it was working great
but some sort of update (firefox i think) has broken this

i used to be able to scale object to correct size and walk around and teleport
now the walk around option is gone, scale changes but in sted of being based on my hight and obj getting bigger and taller it just grows me and the obj at the same time,
kind of like im frowing like alice in wonderland but the object next to me does too

realy nauseating and not good

any ideas

im using HTC vive with firefox 58.01 x64


(Aleahy) #24

Yup WebVR is currently broke - Bug: VR stage is offset when launching WebVR


(Miguelangelo2k) #25

Hi…Is it just me or is WebVR not working at the moment…tried it with Oculus and Vive.
On the monitor it shows the VR view with headtracking but in the headset it doesn’t show…
Nothing on my setup has changed, since 2 or 3 days it doesn’t work…


(Aleahy) #26

Yup. See Bug: VR stage is offset when launching WebVR


(Xmt) #27

I previously reported this in under the VR forum, but am repeating it here just in case it did not get seen by the right people. I have been using Sketchfab with Microsoft Windows Reality and Edge browser without problems for months. In fact, it is really good, so congratulations all round. However, since a couple of weeks ago, the position tracking has stopped working. Rotation works, so I can look around, but if I move, the whole world moves with me. It seems that there is slight positional tracking, but with the wrong scale. In other words, if I take several paces, my virtual position appears to move a tiny bit. My WMR rig still works with other webvr applications, complete with positional tracking. I have WMR systems both at work and at home and they both exhibit the same problem


(Mkhoward) #28

It appears that timing was not on my side because I only started with Sketchfab inside the last couple of weeks, but I have been trying to understand why this doesn’t work. What I found out yesterday though is that it is actually working with some models…something I don’t understand. Are you able to confirm that it is still working on this model: “Base du pigeonnier, Montfa (81)” (Sorry, it won’t let me post a link)

It was for me yesterday, but I am not able to confirm this at the moment. I also found a seemingly random selection of others including a T-Rex and such things, but while those models worked consistently and repeatedly, none of the others do.

As with the OP, mine works on other WebVR sites, plus all other content is tracked normally. The only difference for me is that I wasn’t aware that it used to work. I did try contacting Sketchfab support, but their reply was that they passed my info on to the developers and if any news came back they would let me know.


(Xmt) #29

You are right, “Base du pigeonnier, Montfa (81)” works perfectly. Furthermore, I found that “Fiat C.R 42 " Falco” - Italian Biplane Fighter" has the opposite problem. The position tracking is over-sensitive. If you move towards the plane, it moves towards you; a great way to get sick very quickly. I wonder if it is something to do with the VR scale setting. I just hope it gets fixed soon, because it was working perfectly with all models a while ago.

Just tried changing scale and renderer in 3D VR settings, but the problem remains.


(Diabuz64) #30

Hello

Since today the oculus touchs are badly positioned in vr view mode, they do not move vically (the y axis) when I go up or down the camera.


#31

We just shipped some fixes for VR today, can you try again?


Problems navigating VR in Firefox with HTC Vive
(Diabuz64) #32

Sadly the problem doesn’t fixed. For information I use Firefox 58.0.2 (64 bits).

I made a video youtube to show the bug but the users new can’t post the link. How do you send the link ?

The title of the video is “sketchfab touch issue”, maybe you can find it.

Thank you for your help


(Diabuz64) #33

Thank you.


VR controllers are above my head (Oculus Rift, Firefox)
(Diabuz64) #34

I reported this bug here. Control with oculus touch do not work well


(Dmarcos) #35

I can reproduce the same issue today Feb 27th


#36

Thanks, I’m merging the threads.


(Andgokevin) #37

On Apollo 11 VR and Tomb of Nefertari … the VR controllers are high up, far away, above my head, but they still track. Oculus Touch controllers and Firefox.


(Dmarcos) #38

When scaling in VR mode, the controller does not remain in the correct position where the user’s hand is.

Tested with an Oculus Rift + Firefox on the Van Gogh’s room model. I cannot give the link because the Forum system says I’m a new user and I cannot include links in the post :slight_smile:

I can provide a video if needed via email or any other method.


(Andgokevin) #39

Thanks for merging. Curious if there is an ETA on this fix? We’ve been trying to feature Sketchfab VR content for a while, but it hasn’t been stable for about a week.


#40

I’m afraid there’s no ETA, but our team is investigating. It will be next week at the earliest.