WebVR controller / positional tracking issues


#41

I’ve tried to merge all the forum threads about VR positional / controller tracking here. There was getting to be too many reports of the same bug.


(Diabuz64) #42

The bug is still not fixed with the Oculus.


(Aleahy) #43

Hi, Sketchfab may want to consider temporarily disabling the ‘vr goggle icon’ on the desktop player so the VR mode can’t be entered until this is fixed. Or add a pop-over warning.

It’s just going to keep generating support problems and/or people are going to think their VR systems are broken, or that “VR is just crap”.

PS meanwhile gltf export into webvr using Three.JS is pretty awesome :slight_smile:


(Xmt) #44

Sorry to nag, but is there any update on the broken VR? I’m planning a couple of academic VR demos which were to feature Sketchfab and starting to think about contingency plans.


(Xmt) #45

I have found a workaround which will not only see me through, but should shed some light on the problem. Currenlty, for VR tracking to work correctly (at least with Windows Mixed Reality and I suspect with other systems) you need to set the scale in the VR tab of 3D settings to 1. Changing it here, or using the hand controller when in VR, will mess up positional tracking. Right now, I can change the size of my models in Meshlab as necessary, but I am guessing that it should be reasonably trivial (compared with the mammoth task of making it work in the first place) to un-break this.


#46

Hmm, thanks for the details. Glad you have a workaround for now! We hope to have it fixed soon.


(Diabuz64) #47

Now the positional tracking doesn’t work with oculus and the problem of the controllers still there.

Thanks to your team for working on fixing this bug.


(Xmt) #48

If I reduce the scale (I get smaller, the object gets bigger), then my distance to the object scales down proportionally, as do my positional movements. However, my IPD does not scale, so now my stereo vision is telling me that the object is nearer, but my head movements (try closing one eye) tell me that the object is still further away. I haven’t quite figured what’s happening to the controllers yet, change the scale and they can end up behind you.


(Xmt) #49

My snail (https://sketchfab.com/models/b3eff9af8c6846da8840aef3d579fa66) has been set to unity scale, maybe someone could confirm whether this works with occulus or vive.

As far as I can figure out, this is what’s happening. If I change the scale from 1.0 to 0.5
I get smaller
Head tracking scales down proportionately; so far so good.
Interpupillary distance does not scale down. Object appears closer in stereo vision, Should change proportionately.
Controller positions do not seem to scale. Should change proportionately.

Or of course, maybe its the other way around and the object should get bigger and I stay the same size., in which case IPD and controller positions are scaling up when they should not.

That’s my best guess, but I’ll leave it the the experts to figure out what’s really going on.


(Vrchris) #50

Still not fixed!


(Anatomy Dundee) #51

Hi - this is the first time I’ve been able to check on things since my original post back in Feb! The models are loading better now. Starting on the floor, but touching the touchpad corrects the ground and increases/decreases scale as it should. So the models seem fine. What is off now is the controller, coming in way to high (or low) to be used. On some models the background moves around too, coming closer on the horizon as I move either the headset or controller.

I’m using the orginal Vive on Windows 10.

I’m also about to start using this for an academic study (have volunteers lined up for later this week), so could do with a fix asap if possible. I’ll try XMT’s sugestion for now.

Thanks.


(Anatomy Dundee) #52

Oh, and positional tracking also not working.


#53

We just shipped a release that should fix these issues.


(Anatomy Dundee) #54

Thanks - I am noticing a difference, but still having issues. Some models are close to ok, but the floor is half way up my legs. But on others the model is tiny and way below me. Touching the trackpad doesn’t seem to help. On the plus side the controller does nw appear in my hand! It seems to be those models that are set closest to 1 on the scale that work better.


#55

Hmm, can you post links to the problematic models?


(Anatomy Dundee) #56

Sure, this one was pretty bad: https://skfb.ly/6xCDH
Most of this collection was bad, although the brain was almost right: https://skfb.ly/6vJoP


(Diogofigueiredo) #57

I’ve just tried a couple of models, but it’s not working for me, unfortunately. The problem is different, though. Now the controllers appear correctly in my hands, but I’m hovering about 100 meters above the models, and I can’t find a way to go down to the floor. If I look down, I see a small spotlight-like circle, with the model in the middle, very far away from me.
Anyway, thanks for the effort.

Edit: my specs: Oculus Rift, GTX970 with the latest nvidia drivers, both Firefox and Chrome Canary yielded the same results. Win 10.


(600v) #58

Same with all random models I tried (about 10). Hundred meters above the model and can’t land near it, scaling - only decreasing.
Vive, GTX1080, Firefox, Firefox nightly, Win 10.


(Andgokevin) #59

Yeah, still broken for me on Firefox / Windows / 1080 / Vive.

So most of the time I see nothing except for the model is way below me ((https://sketchfab.com/models/42b6aa9ad71745f3a9abf08a187cf003))

And sometimes my head starts on the ground. (https://sketchfab.com/models/42b6aa9ad71745f3a9abf08a187cf003)

I think it’s important to have the VR viewer work if Sketchfab promotes being able to view models in VR. Would we have to wait for next week again for another deploy attempt?


#60

Did you mean to put the same link twice?