WebVR with the Vive doesn't work


(Moustaches) #1

Hey, first of all I just wanna say that I love you guys for bringing Sketchfab to VR.

Now, my problem here is that I can't get the site to work with WebVR. I'm able to get the menu to load in VR where you select model, I can select a model and it loads, but the controllers either don't render at all, or they render but none of the buttons on it does anything at all.

I've tried first opening the Menu and then turning on the Vive, does not work. I've tried first turning on the Vive and then loading the menu, still doesn't work. I don't really know what else I can try?


Vive Control Navigation Issue
(Waleguene) #2

Hi @moustaches,

Thanks a lot! Much appreciated :slight_smile:
There are issues with controllers on Sketchfab with the last chrome webvr build. It's known but we don't have any fix for now. An easy workaround for this is to use a older build like this one https://drive.google.com/a/sketchfab.com/folderview?id=0BzudLt22BqGRVFdtMElzRnU0aWs&usp=drive_web&tid=0BzudLt22BqGRY1JNbXhpQTNCa2c

Or another one in this list: https://drive.google.com/a/sketchfab.com/folderview?id=0BzudLt22BqGRY1JNbXhpQTNCa2c&usp=drive_web

I hope it helps :slight_smile:
Keep me in touch is you still have issues,

Aurelien


(Moustaches) #3

Thank you! The version you linked to worked beautifully!