What's happening to my model?


(The Timeburner) #1

Greetings!
It's me again,your annoying aspiring artist!

So,I was just wondering why my topology becomes like this when I view it on sketchfab,why?


(Simon Kratz) #2

Hi @the_timeburner!

Could you explain what exactly is wrong? Looks like the wireframe view of your model to me :smile:

Though it looks a bit like it has been auto-generated from curves or some other non-quad topology. It doesn't look like the typical topology that is created by regular polygonal modeling.


(The Timeburner) #3

It's supposed to look like this:


(The Timeburner) #4

I think I this happens when I export it.

This is my preset export settings:

Now,I cant still find out why the mesh is screwed up when I export it. There is no error whatsoever when it finishes exporting.


(Simon Kratz) #5

Ah yes, I think my assumption earlier about the polygon modeling was right. Are you using nurbs for modeling?
In your screenshot Max says you have 0 verts, edges and polygons in the scene so you don't actually see your final polyflow. I guess it's just generated upon exporting.
I'm not really used to non-polygonal modeling methods so I'm not sure how to fix your topology or get nicer results.
I'm pretty sure though that you won't be able to get the exact same topology exported to Sketchfab since Sketchfab can only display polygonal topology.
Maybe you could try to convert your object to an editable poly in max and see what the ProOptimizer or some remeshing tool can do.
Depending on the result some manual cleanup of the resulting topology might do a good job but it's hard to tell.


(The Timeburner) #6

No,it displays 0 because I set it to 'selected'. So,it will only display the statistics of selected objects,and I dont have any selected when I took the screenshot.

It's not nurbs.

As I've said,it seems that the problem is with max,when exporting.


(Simon Kratz) #7

Hmm guess it's pretty hard to tell what's going on from screenshots. Still I'd really like to understand the problem.
If you'd like to send me your file I can take a quick look :smile:
You can just zip and send it to me as PM.


(The Timeburner) #8

I think I fixed it. It seems,that exporting while having isoline display turned on will screw up the mesh. I turned off isoline display and all went fine.

Still WIP

T-34-85 by The_TimeBurner on Sketchfab


(Simon Kratz) #9

Oh nice job! :smiley:
I'm really surprised something that I thought was just a display option messed up the export Oo
But nice to know, I learned something new then :smile:
Cool that it worked for you!