Sketchfab Forum

When I upload blender files with colors it's not showing up [SOLVED]

blender
model
3d
upload

(Vel - Nickname) #1

Hi everyone!

I recently learned how to use Blender and I made two lowpoly models. I'm not new to 3D and I have already uploaded a few models using the "Zipped .mtl and .obj" method. I saw that Sketchfab supports the .blend format so I thought I wouldn't have to use the method above. I even tried using the Sketchfab plugin for blender.

Whether I use the upload button in Blender or choose the file manually, my model shows up without any color. It's blank as if I hadn't any anything color to it at all. Why is this? I'm not coloring it by using the UV maps or the brush feature, I'm selecting the vertices and coloring it that way. No materials or anything.

Here are the models:

https://skfb.ly/SCvy

Thanks in advanced,

Vel.


(Halon Keiser) #2

There are a couple of reasons. First, you do have to go through the whole material --> Texture --> UV Map process.
What's more, the texture can't be one of blender's internal pictures. You have to use an external image, one from some other program.
Then when you upload it to Sketchfab, go into the 3D settings and under the textures tab (it might be called colors) and select your textures in the dropdown menus.
That should work, let me know if it doesn't!


(Waleguene) #3

Hi @VirtualVel,

This is actually an issue on our side. The color is set but an further step in the processing overrides the color with a default one. I opened a issue ticket on our side, thanks for reporting!

In the mean time, you can add "?process_material=1" at the end of the url when being in the 3D editor. It will reprocess the materials and set the right color. Then, just hit "Save settings" and it's done :slight_smile:

Like that: https://sketchfab-local.com/models/f9787759f23a4065a21ac3d739b3ce6e/edit?process_material=1


(Vel - Nickname) #4

Thank you @Halon_Keiser and @waleguene for the help :smiley: !


(Eagle Gamma) #5

Hi,
Is this the same issue affecting this upload?

Please let me know how to fix this.
Thank you!


(Waleguene) #6

@Eagle.Gamma yes.

As you have 7 materials with simple colors/factors, I would recommend you to fix it directly in the 3D editor.
Blender shader nodes are kind of supported but it will be harder to make them work as expected, except if you need to upload a lot of models with these materials.
If it’s the case, maybe you can try with simple nodes in this list:

[Diffuse BSDF, Glossy BSDF, Transparent BSDF]

avoiding to use indirections like “Mix shader”, but still the result is not guaranteed.

For this case I’d go with the 3D Editor


(Eagle Gamma) #7

Thank you, I have edited some of the colors in the Sketchfab 3D editor.