Why does the shadow move in first person?


(Minzkraut) #1

Hello Community

I like to go in first person mode and (kind of) walk through scenes a lot, tho i noticed that the shadows move whenever i look around which kinda destroys the "inside the scene" feeling.
Can i somehow disable that behavior?

Best regards, Minzkraut


Suggestion: Disable "Attached to Camera" for lights in VR mode
#2

My first suspicion is that the lights are attached to the camera. Could you post a link to an example model?


(Minzkraut) #3

Wisteria Garden by Minkyung by mykamyu on Sketchfab


#4

Thanks, I'm looking into it.


#5

Sorry for the delay.

No update yet but I'm hoping we can change this behavior.


#6

Hi again,

We've decided we won't change this behavior for now. We would rather have 'attached to camera' work consistently, so the best solution is to disable it.


(Andrew Leahy) #7

Hi @james, is de-attaching the camera from the lighting only something the scene owner can do?

This is a useful effect on "hero object" scenes, but having the shadows move as you first-person navigate through "world scenes" is very odd.

Perhaps it is something that could be toggled off when camera navigation is in 'fps' mode?

eg. https://sketchfab.com/models/c4192a3708a04c6c9855b5c602689a71

Village by dawkinsia on Sketchfab

Andrew


Suggestion: Disable "Attached to Camera" for lights in VR mode
#8

Yes, only the author can change light/shadow settings.

We hope to revisit this issue in the future, but it's not planned yet.