Sketchfab Forum

Why is this model lit as black?


(Erich) #1

This model used to look fine. See https://sketchfab.com/models/01b45d0a94224a57b20e219a43483fb3

When I go to edit the lighting to see what's wrong, it looks fine. On the main page the model looks black, however. I can provide screen shots if you don't see the same problem.

Chrome, Windows 7, my Quadro K4000 driver is up to date.

Here's what I see: http://s26.postimg.org/5buws4is9/factions_black.jpg

But, then I just tried to reload the page in another browser tab and things were fine! See http://s26.postimg.org/c3lbuz7rt/factions_ok.jpg

I don't know why there's a difference, or what made it go away.


(Johnson Martin) #2

Hello,

Everything looks fine on my end. Did you make sure to let the model load fully? Is the problem still happening? My guess is that it was some kind of WebGL error.

You could try running this WebGL test to check for any errors: http://webglreport.com


(Erich) #3

As I said at the bottom of my post, the model's now working for some reason.

However, I uploaded another model today using the Publish to Sketchfab feature in Mineways (which used to work fine), due to a user reporting a failure. Here's the model:

Blinky - black display via Sketchfab exporter by Eric Haines on Sketchfab

Note the black.

Aurelien Chatelain at Sketchfab figured out a workaround to this server-side bug: edit the model, and then for each and every material select no texture, then select the texture again. However, this should not be necessary - the texture should already be attached.

I did two other tests. In one I manually uploaded the model I exported from Mineways: https://sketchfab.com/models/a9838b7b447e4eb79fca577da264148e

In the other I downloaded the original "black" model and immediately uploaded it again. Doing so is fine: //sketchfab.com/models/0578e93215294ccb832f265d2680b96d

So, what I need to have fixed is the original model: https://sketchfab.com/models/53bb3a685e7942768c890aeac1f98ee9 - why is it black? What is not working on your server? The model itself is clearly OK (I download it and upload it and it then displays correctly).

I want to get this fixed as soon as possible, otherwise I'll need to disable the Publish to Sketchfab feature in Mineways.


(Miekeroth) #4

Hi @erich,
The dashboard has changed a bit, could you look at the specular settings? Could just be it.


(Erich) #5

Thanks, Miekeroth, and I should have been clearer (lovely screenshot, by the way).

I am using Mineways' new Publish to Sketchfab feature. (I wrote most of Mineways, Sketchfab added this feature.) When I use it to directly export to Sketchfab's site, the models are now black. This wasn't the case a week or so ago, the export feature worked fine. I haven't changed anything on my end.

I suspect it's some server weirdness or tiny database glitch, as the problem can be fixed a number of ways:

1) If I edit the model and select no image texture, then select the image texture, the material then displays just fine. This process should not be necessary; I mention it as a diagnostic to the Sketchfab folks.
2) If I export from Mineways to a normal OBJ rendering file and upload it, the model displays correctly.
3) If I download the black model from Sketchfab and upload it again, the uploaded model displays correctly.

It's just the "Mineways -> Publish to Sketchfab" direct path that is no longer working.

Sorry for the confusion.


(Cedric) #6

Not sure what's happen but we will look to fix it asap


(Matthewbrennan) #7

Edit: I was wrong - seems to be something with the model, since it shows up black on my end too.

I've had this happen when the computer runs out of memory. Quit your web browser and/or restart the computer, and it should fix itself. Seems to happen when the computer has no more room to download and store the textures.


(Erich) #8

To all: thanks for your help. Aurelien at Sketchfab says this should be fixed in tomorrow's release of Sketchfab.


(Erich) #9

I'm happy to report the issue has been resolved!

Example: https://skfb.ly/MKKq

By the way, going from annotation #2 to #3 absolutely freaks out the view (try orbiting), which is a bug you may wish to fix.


(Bart) #10

Thanks for letting us know!


#11

There were some strange camera/targets in those annotations. I did my best to improve them.

Art Garden by Eric Haines on Sketchfab


(Erich) #12

I agree, there was a strange transition from annotation 2 to annotation 3. I didn't do anything clever to make this defective thing happen, it came out of the annotation software, so I'm hoping that's where you made the fixes (i.e., fixed the code creating the cameras, vs. just fixing the cameras' data).


#13

cc @stephomi

It's unclear how we should improve annotation camera behavior. Maybe the camera target could default to the annotation point itself?


(Paul Sketch) #14

It's fixed in next release.
( the data for camera eye position and target position where the same, now code handle gracefully that case )